Sunday, August 17, 2008

De vuelta

Tras unas largas vacaciones finalmente he vuelto (casi) a la rutina. Y dentro de mi rutina no podia faltar meterme con ubuntu, que va a ser lo primero que haga.

Justo antes de salir de vacaciones se murió la batería de mi portatil (otra vez, 2 en 2 años) y decidi que ya no iba a comprar mas baterias, que aguantaría sin batería hasta que me comprara un portatil nuevo. Y bien, aguanté un par de días. Dado que el adaptador AC no es el original (también murió), en cuanto se lo toca se corta la corriente lo justo como para que el portatil se apague. Total, que tocaba comprarse un portatil y rápido, para poder empezar a currar lo antes posible.

En cuanto al portatil express fue relativamente sencillo, un viaje al centro de comercial, PC City, MediaMarkt, un par de tiendas mas y solucionado. Un HP muy majete, pero claro... con Windows Vista. Tras 4 horas quitar porqueria y crear DVDs de backup, tocaba instalar linux.

Dado que el portatil fue comprado ayer y tiene que estar listo mañana, Gentoo estaba descartado. Quedaban las opciones "fáciles": Mandriva, openSUSE, Kubuntu, Fedora... y como todo el mundo en la oficina usaba Kubuntu, pues muy a mi pesar, decidi probarlo.

A primera vista no esta mal, detecta la wifi 4965, el sonido, las teclas del volumen... ¡incluso me ofrece instalar los drivers de nVidia! Y ahi empieza el show. En cuanto selcciono los drivers, sale una ventana del adept con un popup diciendo directamente que ha fallado. La ventana del adept tiene un boton "Detalles" para ver los motivos del fallo, pero no permite pulsarlo ya que esta el popup. Y en cuanto se cierra el popup, se cierra automatciamente el adept. Nada, no ha habido suerte.

Siguiente parte: panel de control. Un fallo lo tiene cualquiera, asi que voy a hacerlo desde el panel de control. Abro el panel de control, voy a opciones de pantalla, y veo que se puede elegir entre driver "estandar" o "propietario". Estupendo, si no fuera porque esta en gris y no se puede cambiar. Total, actualizo el sistema y reinicio.

Parte III: Automático de nuevo. En cuanto arranca, me vuelve a preguntar si quiero instalar el driver propietario de nVidia. De nuevo arranca el adept y finaliza con el error "Debe ejectuar este programa con permisos de admin". Que bien, el programa arranca solo, pero arranca mal. Para eso, no arranques y deja de tocar la moral.

Otro intento: instalacion manual. Dado que el adept no ha podido instalar los drivers por falta de permisos, lo hago yo a mano. Voy al panel de control y nada: la opcion estandar/propietario sigue en gris. Reinicio y nada: sigue con error de permisos.

Captiulo 1834: "La busqueda del programa". Busco el asistente que salta al inicio y lo ejecuto desde el menu. El asistente ya no da error de permisos, desinstala un par de modulos de nvidia y me pide reiniciar KDE. Reinicio KDE: no responde. Reinicio el portail: las X no arrancan y tengo a mi disposicion una bonita consola.

Desenlace: para configurar el driver acabo teniendo que hacerlo como en Gentoo: a manita, desde la consola y tocando archivos de configuracion, pero previemente perder 20 minutos intentando usar la herramientas de Ubuntu.

Epílogo: como bonus, la suspension no funciona y sigue sin poderse cerrar sesion, ya que las X se quedan bloqueadas. En cuanto me ponga a hacer mas cosas, seguro que no sera lo único que no funciona. Si lo llego a saber instalo Mandriva, ya que openSUSE 11 tampoco me ha convencido, pero eso ya es otra historia.

1 comment:

gorriz said...

se ve que nuna tendremos el ordenador perfecto, aquel al que cuando le conectas la xbox no tiene q pasarte 5 horas configurando cosas hasta q te deja usar internet compartido XD